< Knowledge Base

Troubleshoot the Router's 3G/4G/LTE Connection

Published On: Apr 21, 2015 

If the 3G/4G/LTE connection is not working on your Vigor Router, you may try the following steps to troubleshoot.

Check if the USB modem is in the Support List

The supported models may vary between firmware versions. You can find the latest USB dongles supported by the router from Application >> Modem Support List on the router's user interface.

a screenshot of router's GUI
Make sure the Access Mode is correct

Note that Vigor Router provides two access modes, PPP and DHCP. The selection affects how will the router exchange data with the dongle, and the wrong settings may cause the connection to fail. Check the Support List to find the right one to use, or just try the other one if the current setting is not working.

Upgrade the firmware to the latest version

The latest firmware includes improvements and fixes to known issues. If the router's firmware is not the latest version, upgrade the firmware and try again.

Check the validity of your SIM card

Make sure you are using a valid SIM card, not expired, data not used up yet.

Enter the right PIN code

Check if you have entered the right PIN code. Leave the PIN code field blank if the SIM card does not have one, which is also quite common. 

Check the WAN configuration

Confirm the configuration in WAN >> Internet Access again. Make sure have entered the APN, username, and password that your ISP provided.

E-mail to support

If none of the above solve the issue, please provide the following information to our Technical Support for further analysis.

Was this helpful?     


Related Articles